const regex = new RegExp('(?:\\A|\\n{2})(?:(?!\\n{2}).)+\\.(?=\\n{2}|\\Z)', 'gs')
const str = `Diagnosis of one of the following: A) Neovascular (wet) age-related
macular degeneration OR B) Macular edema following retinal vein
occlusion, OR C) Diabetic macular edema OR D) Diabetic retinopathy in
patients with diabetic macular edema. More text here.
PA Criteria
Criteria Details
Eylea (s)
Products Affected
EYLEA
Exclusion
Criteria
Required
Medical
Information
Age Restrictions
Prescriber
Restrictions
Coverage
Duration
Other Criteria
Off Label Uses
12 months
Indications
All Medically-accepted Indications.
Formulary ID 20276, Version 12
101`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}