import re
regex = re.compile(r"(?:\A|\n{2})(?:.|\n(?!\n))+\.(?=\n{2}|\Z)")
test_str = ("Diagnosis of one of the following: A) Neovascular (wet) age-related\n"
"macular degeneration OR B) Macular edema following retinal vein\n"
"occlusion, OR C) Diabetic macular edema OR D) Diabetic retinopathy in\n"
"patients with diabetic macular edema. More text here.\n\n"
"PA Criteria\n\n"
"Criteria Details\n\n\n"
"Eylea (s)\n\n"
"Products Affected\n"
" EYLEA\n\n"
"Exclusion\n"
"Criteria\n\n"
"Required\n"
"Medical\n"
"Information\n\n"
"Age Restrictions\n\n"
"Prescriber\n"
"Restrictions\n\n"
"Coverage\n"
"Duration\n\n"
"Other Criteria\n\n"
"Off Label Uses\n\n\n\n\n\n\n\n\n\n\n\n"
"12 months\n\n"
"Indications\n\n"
"All Medically-accepted Indications.\n\n"
"Formulary ID 20276, Version 12\n\n"
"101")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")