re = /(?:\A|\n{2})(?:.|\n(?!\n))+\.(?=\n{2}|\Z)/
str = 'Diagnosis of one of the following: A) Neovascular (wet) age-related
macular degeneration OR B) Macular edema following retinal vein
occlusion, OR C) Diabetic macular edema OR D) Diabetic retinopathy in
patients with diabetic macular edema. More text here.
PA Criteria
Criteria Details
Eylea (s)
Products Affected
EYLEA
Exclusion
Criteria
Required
Medical
Information
Age Restrictions
Prescriber
Restrictions
Coverage
Duration
Other Criteria
Off Label Uses
12 months
Indications
All Medically-accepted Indications.
Formulary ID 20276, Version 12
101'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end