# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?:\w+['’])?@(\S+)"
test_str = ("1. take this -> @Mark\n"
"2. take this -> @mark_2\n"
"3. take this -> @中国\n"
"4. take this -> l'@antro\n"
"4.1 take this -> all'@antro\n"
"4.2 take this -> dell'@antro\n"
"5. don't take this -> 中国@中国.zh\n"
"6. don't take this -> 中国@google.zh\n"
"7. don't take this -> info@google.com\n"
"8. don't take this -> 99@test.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.