re = /(?<!\S)(?:\w+['’])?@(\S+)/m
str = '1. take this -> @Mark
2. take this -> @mark_2
3. take this -> @中国
4. take this -> l\'@antro
4.1 take this -> all\'@antro
4.2 take this -> dell\'@antro
5. don\'t take this -> 中国@中 国.zh
6. don\'t take this -> 中国@google.zh
7. don\'t take this -> info@google.com
8. don\'t take this -> 99@test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end