#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([\w]+):+[\/]+([\w.]+))?([\/\w.]*)\?*([\w=.&]*)\#*([\w]*)$"
Local $sString = "mujin:/a.mujin.json" & @CRLF & _
"mujin://b.mujin.json" & @CRLF & _
"/long/path/file.json" & @CRLF & _
"long/path/file.json" & @CRLF & _
"http://mujin.co.jp/path/file.json" & @CRLF & _
"http://mujin.co.jp/path/file.json?type=json" & @CRLF & _
"http://mujin.co.jp/path/file.json?type=json&scheme=mujin" & @CRLF & _
"http://mujin.co.jp/path/file.json?type=json#robot1" & @CRLF & _
"http://mujin.co.jp/path/file.json#robot1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")