import Foundation
let pattern = ##"^(([\w]+):+[\/]+([\w.]+))?([\/\w.]*)\?*([\w=.&]*)\#*([\w]*)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
mujin:/a.mujin.json
mujin://b.mujin.json
/long/path/file.json
long/path/file.json
http://mujin.co.jp/path/file.json
http://mujin.co.jp/path/file.json?type=json
http://mujin.co.jp/path/file.json?type=json&scheme=mujin
http://mujin.co.jp/path/file.json?type=json#robot1
http://mujin.co.jp/path/file.json#robot1
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)