package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)\(.*\)`)
var str = `Алан Тьюринг (1912 - 1954), Джон фон Нейман (1903 - 1957)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}