$re = '/\(.*\)/U';
$str = 'Алан Тьюринг (1912 - 1954), Джон фон Нейман (1903 - 1957)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);