const regex = /^[-+]?[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?[0-9]+$', 'gm')
const str = `float varieties:
4848.48
+01.20
0.45
01.45
20.20
20.2000000
-1.23
-0.23
0.0
0.00000
.3
-.4
+.4
+.30
+1.1
+00001.1
int varieties:
1234
43210
12012
+1
0
-0
+0
01234
000001234
+00
-00
+00123
-00123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}