import re
regex = re.compile(r"^[-+]?[0-9]+$", flags=re.MULTILINE)
test_str = ("float varieties:\n\n"
"4848.48\n"
"+01.20\n"
"0.45\n"
"01.45\n"
"20.20\n"
"20.2000000\n"
"-1.23\n"
"-0.23\n"
"0.0\n"
"0.00000\n"
".3\n"
"-.4\n"
"+.4\n"
"+.30\n"
"+1.1\n"
"+00001.1\n\n"
"int varieties:\n\n"
"1234\n"
"43210\n"
"12012\n"
"+1\n"
"0\n"
"-0\n"
"+0\n"
"01234\n"
"000001234\n"
"+00\n"
"-00\n"
"+00123\n"
"-00123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")