#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?(?:0|[1-9][0-9]*)$"
Local $sString = "float varieties:" & @CRLF & _
"" & @CRLF & _
"4848.48" & @CRLF & _
"+01.20" & @CRLF & _
"0.45" & @CRLF & _
"01.45" & @CRLF & _
"20.20" & @CRLF & _
"20.2000000" & @CRLF & _
"-1.23" & @CRLF & _
"-0.23" & @CRLF & _
"0.0" & @CRLF & _
"0.00000" & @CRLF & _
".3" & @CRLF & _
"-.4" & @CRLF & _
"+.4" & @CRLF & _
"+.30" & @CRLF & _
"+1.1" & @CRLF & _
"+00001.1" & @CRLF & _
"" & @CRLF & _
"int varieties:" & @CRLF & _
"" & @CRLF & _
"1234" & @CRLF & _
"43210" & @CRLF & _
"12012" & @CRLF & _
"+1" & @CRLF & _
"0" & @CRLF & _
"-0" & @CRLF & _
"+0" & @CRLF & _
"01234" & @CRLF & _
"000001234" & @CRLF & _
"+00" & @CRLF & _
"-00" & @CRLF & _
"+00123" & @CRLF & _
"-00123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")