use strict;
my $str = 'float varieties:
4848.48
+01.20
0.45
01.45
20.20
20.2000000
-1.23
-0.23
0.0
0.00000
.3
-.4
+.4
+.30
+1.1
+00001.1
int varieties:
1234
43210
12012
+1
0
-0
+0
01234
000001234
+00
-00
+00123
-00123
';
my $regex = qr/^[-+]?(?:0|[1-9][0-9]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}