$re = '/(\d+)\s+(years?|months?|weeks?|days?)/i';
$str = '1 year
10 months
3 days
7 weeks
1 yEaR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);