re = /(\d+)\s+(years?|months?|weeks?|days?)/i
str = '1 year
10 months
3 days
7 weeks
1 yEaR
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end