using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\_.{1}(.).*\_";
string input = @"1836248_NNY_01.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}