$re = '/\_.{1}(.).*\_/m';
$str = '1836248_NNY_01.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);