package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d+) <(\w+)> (\d+) (\d+) (\d+) (?:(\d+) )?</\w+>$`)
var str = `1111 <CARRE> 123 321 111 222 </CARRE>
2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>
3333 <CERCLE> 345 543 555 </CERCLE>
4444 <OVALE> 456 654 666 777 </OVALE>
5555 <LIGNE> 567 765 888 999 </LIGNE>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}