re = /^(\d+) <(\w+)> (\d+) (\d+) (\d+) (?:(\d+) )?<\/\w+>$/
str = '1111 <CARRE> 123 321 111 222 </CARRE>
2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>
3333 <CERCLE> 345 543 555 </CERCLE>
4444 <OVALE> 456 654 666 777 </OVALE>
5555 <LIGNE> 567 765 888 999 </LIGNE>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end