import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#\\d\\s*–\\s*\\d*\\.?\\d+\\s+[a-zA-Z]+\\s+\\$\\d*\\.?\\d+$";
final String string = "#1 – .75 Gallon $16.99\n"
+ "#2 –1.6 Gallon $36.99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}