re = /^#\d\s*–\s*\d*\.?\d+\s+[a-zA-Z]+\s+\$\d*\.?\d+$/m
str = '#1 – .75 Gallon $16.99
#2 –1.6 Gallon $36.99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end