re = /(?:ACT|SCENE).+?\d+|\S.*?(?=\s?(?:ACT|SCENE|$))/m
str = 'Hi this is ACT I. SCENE 1 and SCENE 2 and this is ACT II. SCENE 1 and SCENE 2 and more'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end