using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{(?:(?<if>if(?=\s+))|(?<elseif>if:elseif(?=\s+)))\s*((?:[^""]*?|""[^""]*"")*)\s*}";
string input = @"{if layout:test == ""test"" || another == ""}""}
{if:elseif param == ""value""}
{if:else}
{/if}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}