$re = '/{(?:(?<if>if(?=\s+))|(?<elseif>if:elseif(?=\s+)))\s*((?:[^"]*?|"[^"]*")*)\s*}/';
$str = '{if layout:test == "test" || another == "}"}
{if:elseif param == "value"}
{if:else}
{/if}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);