const regex = /(\d+-\d+\n*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+-\\d+\\n*)', 'g')
const str = `111-11111
222-999
222
111-222
555-4566
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}