$re = '/(\d+-\d+\n*)/';
$str = '111-11111
222-999
222
111-222
555-4566
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);