#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|¯\\_\(ツ\)_/¯)(\(\w+\))?(!)?(: (.*\s*)*))|(Merge (.*\s*)*)|(Initial commit$)"
Local $sString = "Merge from masterasdfasdfasdf asdfasdf" & @CRLF & _
"asdfasdfasdflkjadsfkaj asdf" & @CRLF & _
"### asdfasdfasdf" & @CRLF & _
"# https: -asdfasdf" & @CRLF & _
"### monkey " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")