re = /^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|¯\\_\(ツ\)_\/¯)(\(\w+\))?(!)?(: (.*\s*)*))|(Merge (.*\s*)*)|(Initial commit$)/m
str = 'Merge from masterasdfasdfasdf asdfasdf
asdfasdfasdflkjadsfkaj asdf
### asdfasdfasdf
# https: -asdfasdf
### monkey
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end