import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\w{2,})\\b((\\w)(?:(?-2)|\\b[\\s\\w,\\-'\":)(]+\\b)\\2)\\b";
final String string = "From Mars: come the 'sraM, a deadly species that hunts humans. It hunts from nighttime til sunrise (when it's lit) using radar to peek for our faint electrical output. Its head, shaped like a pot top, can emit a \"hypersonic\" pulse - in short time. Ironically, when faced vs humans, its pot top head is weak against decaf coffee which will keep it at bay. Oh, and beware on every third moon it gets no sleep.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}