$re = '/(?=\w{2,})\b((\w)(?:(?-2)|\b[\s\w,\-\'":)(]+\b)\2)\b/';
$str = 'From Mars: come the \'sraM, a deadly species that hunts humans. It hunts from nighttime til sunrise (when it\'s lit) using radar to peek for our faint electrical output. Its head, shaped like a pot top, can emit a "hypersonic" pulse - in short time. Ironically, when faced vs humans, its pot top head is weak against decaf coffee which will keep it at bay. Oh, and beware on every third moon it gets no sleep.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);