# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\<\%[\w \@\=\.\*\,\"\$\#\!\&\(\)\/\/\n\+\;\:]*"
test_str = ("<%@ page import=\"java.io.*,java.util.*\" %>\n"
"<html>\n"
" <head>\n"
" <title>Auto Refresh</title>\n"
" </head>\n"
" <body>\n"
" <fieldset style=\"width:20%; background-color:#e6ffe6;\">\n"
" <legend>Auto refresh</legend>\n"
" <h2>Auto Refresh Example</h2>\n"
" <%\n"
" // Set refresh, autoload time as 1 seconds\n"
" response.setIntHeader(\"Refresh\", 1);\n"
" // Get current time\n"
" Calendar calendar = new GregorianCalendar();\n"
" String am_pm;\n"
" int hour = calendar.get(Calendar.HOUR);\n"
" int minute = calendar.get(Calendar.MINUTE);\n"
" int second = calendar.get(Calendar.SECOND);\n"
" if(calendar.get(Calendar.AM_PM) == 0)\n"
" am_pm = \"AM\";\n"
" else\n"
" am_pm = \"PM\";\n"
" String CT = hour+\":\"+ minute +\":\"+ second +\" \"+ am_pm;\n"
" out.println(\"Crrent Time: \" + CT + \"\\n\");\n"
" %>\n"
" </fieldset>\n"
" </body>\n"
"</html>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.