import Foundation
let pattern = #".*\n.*\n.*": "(.*)"\n.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"timestamp": [3344, 3345.04],
"text": " אבל הוא גם יעלה."
},
{
"timestamp": [3347.04, 3349.74],
"text": " בזה, בא מיד ביטחון התשובה,"
},
{
"timestamp": [3349.74, 3351.74],
"text": " להתעלות האדם גם אחרי הירידות כולן,"
},
{
"timestamp": [3351.74, 3353.24],
"text": " שאפשר להן להמצא בחיים,"
},
{
"timestamp": [3353.24, 3355.04],
"text": " תשב אנוש עד דכא"
},
{
"timestamp": [3355.04, 3356.4],
"text": " ותאמר שובו בני אדם."
},
{
"timestamp": [3356.4, 3362.04],
"text": " ברור, אמרת ואפשרת וברור שבסוף כל האדם וכל המציאות תשוב למקורה."
},
{
"timestamp": [3362.04, 3363.04],
"text": " בסדר?"
},
{
"timestamp": [3363.04, 3364.57],
"text": " טוב."
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)