using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*-(?<file_name>[^-]*)-\w+-\w+$";
string input = @"Operating System-Linux-Server-Support-GENVE0001VA.gmail.com.au-GEN-Adm02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}