$re = '/^.*-(?<file_name>[^-]*)-\w+-\w+$/m';
$str = 'Operating System-Linux-Server-Support-GENVE0001VA.gmail.com.au-GEN-Adm02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);