const regex = /^buy_towars_\([\w*.]+\)_press$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^buy_towars_\\([\\w*.]+\\)_press$', 'gm')
const str = `buy_towars_(3821731.mol)_press
buy_towars_(m*ilk)_press`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}