re = /^buy_towars_\([\w*.]+\)_press$/m
str = 'buy_towars_(3821731.mol)_press
buy_towars_(m*ilk)_press'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end