package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\u{0080}-\u{017F}\u{1E00}-\u{1EFF}]+`)
var str = `Ngeasdf
##@fdsa
1234532
D'angelo
Hel~lo
ñ
[a-zA-Z'~\w]+
^0-9
1E00-1EFF
\u0000-\u007F
[^\\w'~a-zA-z\s]+
\u0080-\u00FF\u0100-\u017F\u0180-\u024F
\u{0080}-\u{017F}\u{1E00}-\u{1EFF}
ÃãÑñÕõŨũṼṽỸỹẼẽĨĩ
[^\\w'~a-zA-Z\sÃãÑñÕõŨũṼṽỸỹẼẽĨĩ]+
Ṽ U+1E7C
ṽ U+1E7D
Ỹ U+1EF8
ỹ U+1EF9
Ẽ
ẽ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}