const regex = /[\u{0080}-\u{017F}\u{1E00}-\u{1EFF}]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\u{0080}-\\u{017F}\\u{1E00}-\\u{1EFF}]+', 'gu')
const str = `Ngeasdf
##@fdsa
1234532
D'angelo
Hel~lo
ñ
[a-zA-Z'~\\w]+
^0-9
1E00-1EFF
\\u0000-\\u007F
[^\\\\w'~a-zA-z\\s]+
\\u0080-\\u00FF\\u0100-\\u017F\\u0180-\\u024F
\\u{0080}-\\u{017F}\\u{1E00}-\\u{1EFF}
ÃãÑñÕõŨũṼṽỸỹẼẽĨĩ
[^\\\\w'~a-zA-Z\\sÃãÑñÕõŨũṼṽỸỹẼẽĨĩ]+
Ṽ U+1E7C
ṽ U+1E7D
Ỹ U+1EF8
ỹ U+1EF9
Ẽ
ẽ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}