package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(.*)\/city`)
var str = `/alameda/city/
/oakland/city/
/san-francisco/city/
/san-jose/city/
/fremont/city/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}