$re = '/\/(.*)\/city/m';
$str = '/alameda/city/
/oakland/city/
/san-francisco/city/
/san-jose/city/
/fremont/city/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);