$re = '/^(?>[\w+\-.%]+@gmail\.com(?:;\s*|$))+$/m';
$str = '1@gmail.com%2@gmail.com
1@gmail.com&&2@gmail.com
1@gmail.com;2@gmail.com
1@gmail.com; 2@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);