re = /^(?>[\w+\-.%]+@gmail\.com(?:;\s*|$))+$/m
str = '1@gmail.com%2@gmail.com
1@gmail.com&&2@gmail.com
1@gmail.com;2@gmail.com
1@gmail.com; 2@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end