const regex = /([\s\S].*?)((hardrock)[^-]|hardrock$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S].*?)((hardrock)[^-]|hardrock$)?', 'gm')
const str = `matt,hardrock,victor,ben,hardrock,rocker,ranzian,hardrock,hardrock,victor,alpha,matt,hardrock-victor,ben,hardrock,rocker,ranzian,hardrock,matt,hardrock,victor,ben,hardrock,rocker,ranzian,hardrock,hardrock,victor,alpha,matt,hardrock-victor,ben,hardrock,rocker,ranzian,hardrock`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);