$re = '/<!--[^-]*(?:-(?!->)[^-]*)*-->|>([^<]*)</m';
$str = '<a href=\'link.html\'>URL</a>Some
text <!-- Comment --><p>Par
here</p>More text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);