re = /<!--[^-]*(?:-(?!->)[^-]*)*-->|>([^<]*)</m
str = '<a href=\'link.html\'>URL</a>Some
text <!-- Comment --><p>Par
here</p>More text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end