use strict;
my $str = 'desc_125f.jpg -> matched,
desc#_56.jpg -> not matched (contains #),
bla_bla.gif -> matched,
bla_bla.png -> not matched (extension is png),
desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),
desc_min256.gif';
my $regex = qr/^\w++(?<!_min)\.(jpg|gif)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}