$re = '/[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}/i';
$str = '5c251366-f548-4aaf-a1cc-3dc3372d1302
c54579ac-1e3c-41ab-a020-1eaf2de425ab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);