re = /[A-Z](?:[a-z]+|[A-Z]+(?![a-z]))?|\d+/m
str = 'Hello123AIIsCoolAndHTML5IsAMarkupLanguage'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end